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In this lab, we consider methods for examining network topography. We begin with network size, 
and then explore several that measure network cohesiveness: density, average degree, clustering 
coefficient, fragmentation, the E-I index, average distance, and diameter. Size is the number of 
actors in a network. Density is the number of actual ties divided by the total possible ties. 
Unfortunately, it is inversely related to network size (i.e., the larger the network, the lower the 
density) because the number of possible lines increases exponentially as actors join the network, 
which is why SNA researchers sometimes turn to other measures, such as average degree and the 
clustering coefficient. Network fragmentation is the proportion of all pairs of actors that are not 
tied (directly or indirectly) with one another. The E-I index measures the ratio of external to 
internal ties (good for determining how isolated a network is). Average distance is the average 
length of all the shortest paths (i.e., geodesics) between all actors in a network, and diameter is a 
network’s longest geodesic. Finally, we consider several metrics that capture how hierarchical a 
network is: centralization, variance, and standard deviation. This lab shows how to estimate all of 
the measures in UCINET and Pajek. Once again we will use the Anabaptist Leader network data, 
which are included in the zipped file, SNA Basics #5(Data).zip. 
 

Part I – Network Topography in UCINET 
 
1. Let’s begin by calculating network density. Select the Network>Cohesion> 

Density>(new)Density Overall command. This callus up a dialog box (not 
shown). Select the Anabaptist Leaders.##h file. Click OK. The resulting 
output (Figure 1) gives you density of the network. As you can see, it equals 
 

 
Figure 1: Output of Overall Density Command (Anabaptist Leadership Network) 

2. If we issued this command with a stacked network (e.g., the Sampson novice data 
that we used in the previous lab), it gives us scores for all of the networks in the 
file (Figure 2, next page). Notice, however, that what UCINET reports is a bit 
different from that above. Because the Sampson data are weighted (the novices 
ranked their fellow novices from 3 to 1), UCINET calculates average value and 
weighted average degree. If we dichotomize (binarized) the network, and then 
issue the command, UCINET gives us an output like that in Figure 3 (next page). 
 

[UCINET] 
Network>Cohesion 

>Density 
>Density Overall 

Network>Cohesion 
>Density 

>Density Overall 
 
 
 

Transform>Dichotomize 
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Figure 2: Output of Overall Density Command (Sampson’s Novices – Weighted) 

 

Figure 3: Output of Overall Density Command (Sampson’s Novices – Binarized) 

3. Network density is the ratio of actual ties divided by all possible ties. However, 
density scores tend to decrease as social networks get larger because the number 
of possible ties increases exponentially, whereas the number of ties that each 
actor can maintain is limited. Consequently, we can only use it to compare 
networks of the same size. An alternative is average degree centrality, which is 
not sensitive to network size and thus can be used to compare different sized 
networks. If you look again at Figures 1 and 3, you will note that UCINET’s 
density output also provides the average degree of each network (column 4). 
 

4. Another measure used to capture the overall level of cohesion is the clustering 
coefficient. It is estimated by first identifying each actor’s ego network (i.e., each 
actor’s ties to other actors – “alters” – and the ties between them), then 
calculating the density of each ego network (without including ego’s ties), and 
then averaging the ego-network density scores for all of the actors in the network. 
It is also known as ego-network density. To get this score, select the Network> 
Cohesion>Clustering Coefficient command. In the resulting dialog box (not 
shown) select the “Anabaptist Leaders.##h” network and click OK. 

 
 
 
 
 
 

Network>Cohesion 
>Clustering Coefficient 
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5. Fragmentation and cohesiveness are additional measures for estimating a 
network’s internal connectivity. They are additive inverses of each and range 
from 0.0 to 1.0 where a network composed entirely of isolates will have a 
cohesiveness score of 0.0 (and a fragmentation score of 1.0) and a network where 
every actor is connected (either directly or indirectly) to every other actor will 
have a cohesive score of 1.0 (and a fragmentation score of 0.0). You estimate 
these using UCINET’s Network>Centrality and Power>Fragmentation 
command. Unfortunately, it only works on single networks, so if you have a 
stacked network, you need to unpack it with the Data>Unpack command. 
UCINET reports two sets of scores: (1) the standard fragmentation score, which is 
the proportion of all pairs of actors that are not connected with one another, and 
(2) a distance-weighted score that weights this score by the path distance between 
all pairs. Another helpful feature is that it reports a series of scores that indicate 
(1) what the network fragmentation would be if a particular actor is removed 
(“Frag”); (2) what the distance weighted network fragmentation will be if the 
actor is removed (“DwFrag”); (3) the change in network fragmentation when a 
particular node is removed (“FragDiff”); (4) the change in distance-weighted 
network fragmentation when node is removed (“DwFragDiff”); (5) the percent of 
fragment change (“PctFragChg”); and (6) the percent of distance-weighted 
fragment change (“PctFragChg”). 
 

6. The E-I index compares the ratio of internal to external ties. It ranges from -1.00 
to 1.00 where a score of -1.00 indicates that the network has only internal ties and 
a score of 1.00 indicates that it only has external ties. It’s calculated using the 
Network>Cohesion>E-I Index command and requires both a network and an 
attribute file. The latter is needed to indicate which groups actors belong to. Here 
we will use the attribute that distinguishes between those Anabaptists who 
Melchiorites and those who were not. You can view this attribute file with the 
Data>Display command; the “Melchiorite” attribute is located in column 6 (see 
Figure 4). Note that the “L” speed button is a way to select the attribute that you 
hope to use. 
 

 
Figure 4: UCINET’s E-I Index Dialog Box 

 
 
 
 
 
 
 

Network 
>Centrality and Power 

>Fragmentation 
 

Data>Unpack  
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>Cohesion>E-I Index 
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7. After clicking OK, UCINET’s output will be similar to that shown in Figure 5. 
Note that it is quite extensive. The top of the report provides overall information 
on both networks; to get the E-I index of the two subgroups, you have to scroll 
down the report until you find the “Group Level E-I Index.” There you can see 
that the E-I index for the Melchiorites (group 2) equals -0.824, which tells us that 
the Melchiorite leaders had very few ties to non-Melchiorites. The score for the 
other group is somewhat meaningless because it really isn’t a distinct group; it 
includes Anabaptists, Lutherans, and Reformed Protestants. All they share in 
common is that they aren’t Melchiorites. 
 

 
Figure 5: UCINET’s E-I Index Output 

8. Average distance and diameter can be calculated in UCINET using the Network> 
Cohesion>Geodesic Distance (old) command. Like the fragmentation command, 
this command only works on single networks. The output (Figure 6) first 
indicates the average (path) distance among reachable pairs (since not all actors 
can reach one another). This is followed by the distance-weighted measures of 
fragmentation and cohesiveness (rather than the standard measures of 

Network>Cohesion 
>Geodesic Distance 

(legacy) 
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fragmentation and cohesiveness), which in turn are followed by the number of 
geodesics at various distance levels (from shorter to longer). The largest geodesic 
level equals the network’s diameter. Just looking at the output in Figure 6, what 
is the leadership network’s average distance and diameter? Now compare it to 
the output in Figure 8 to make sure that, like Indiana Jones, you chose wisely. 
 

 
Figure 6: UCINET’s Old Geodesic Output 

9. Finally, UCINET recently added a function that calculates multiple cohesion 
measures: Network>Multiple cohesion measures, which calls up a dialog box 
similar to Figure 7. It calculates 23 different measures, including many of the 
ones discussed above (except size, clustering coefficient, and the E-I index) plus 
degree centralization. Thus, it can be quite useful (see Figure 8). 
 

 
Figure 7: UCINET’s Multiple Cohesion Measures Dialog Box 

 

 
Network 

>Multiple cohesion 
measures 
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Figure 8: UCINET’s Multiple Cohesion Measures Output 

10. Network centralization, variance, and standard deviation are measures that can 
capture the hierarchical dimension of a network’s topography. They help 
researchers determine how hierarchical (or non-hierarchical) a network. 
Centralization uses the variation in actor centrality (as compared to the highest 
centrality score) within the network to measure the level of centralization. More 
variation yields higher network centralization scores, while less yields lower 
scores. In general, the larger a centralization index is, the more likely it is that a 
single actor is very central while the other actors are not. Thus, the index can be 
seen as measuring how unequal the distribution of individual actor scores are. 
Because we can calculate centralization using different measures of centrality 
(e.g., degree, betweenness, closeness, and eigenvector), we need to interpret the 
results in light of the type of centrality used. 
 

11. Variance and standard deviation are similar to centralization. They differ from 
centralization in that rather comparing individual scores to the highest centrality 
score, they compare individual scores to the average centrality score. Because 
standard deviation is the square root of the variance, it is probably preferable to 
variance because it returns it returns to the original unit of analysis.1 If you look at 
Figure 9 (next page), you will note that the network centralization score appears 
just below the descriptive statistics, whereas the variance and standard deviation 
are “buried” in the descriptive statistics themselves. Centralization scores range 
from 0.00 – 1.00 (or 0 – 100%) when analyzing dichotomized data. If you are 
analyzing valued data, centralization scores will sometimes be larger than 1.00; 
thus, it’s generally a good idea to dichotomize your data before estimating 
network centralization. 

                                                
1 Variance is calculated by taking the sum of the squared differences between the mean and 
each score. Thus, by taking its squared root, we return to the original unit of analysis. 
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12. The various centralization scores are calculated with UCINET’s Network> 
Centrality and Power>_Degree (legacy), Closeness (old), Freeman Betweenness, 
Eigenvector centrality commands. If you use the degree command, a dialog box 
will appear (not shown) in which you should tell UCINET to treat the data as 
symmetric because you are working with undirected data. The default should be 
“Yes” but for some reason its “No.” Click OK, and after UCINET generates the 
output file, scroll down past the individual centrality scores for each network, and 
you will find the centralization, standard deviation, and variance scores (circled in 
Figure 9). You will have to scroll to the bottom of each network to get the 
centralization scores. 
 

 
Figure 9: UCINET’s Centralization Scores 

 
Part II – Network Topography in Pajek 

 
1. Open the “Anabaptist Leaders.paj” project file using the File>Pajek 

Project File>Read command (or the F1 key) – be sure to read in the project file 
as a project file, not a network file. Before calculating density and average 
degree, we need to first check if the network is symmetric. We do this by clicking 
on the network information button (circled in Figure 10) or by using the 
Network>Info>General command. This will bring up a dialog box, asking you 
whether you want the highest or lowest ranked ties; here, we don’t care, so accept 
Pajek’s default and click okay. This will generate a report (Figure 11) where we 
can see that the network only consists of edges, which means that the network is 
indeed symmetric. If the network wasn’t symmetric, we’d first use the Network> 
Create New Network>Transform>Arcsà Edges>All command, which brings up 
a dialog box asking whether we want to create a new network. Typically, we 
select yes so that we don’t overwrite any existing networks. Next, Pajek will ask 
us whether we want to remove multiple lines. Usually, that’s a good idea, so we 
can select the “Single” option (#5).  
 

Network 
>Centrality and Power 

>_Degree (legacy),  
Closeness (old),  

Freeman Betweenness, 
Eigenvector centrality 

[Pajek] 
File>Pajek Project File 

>Read  
 
 
 

Network>Info>General 
 
 
 
 

Network>Create New 
Network>Transform 
>Arcsà Edges>All 



SNA Basics #5 
Topography of Social Networks 

 

ã Sean F. Everton  
 

8 

 
Figure 10: Pajek Main Screen 

 
Figure 11: Pajek Network General Info Report 

2. Looking at the network general information report in Figure 11, you can see that 
the network included multiple lines. Because this is a symmetric network, what 
this means is that Pajek is interpreting the edges as reciprocal and thus counting 
them twice (note that the number of multiple lines is exactly half of the total 
number of edges). Thus, we need to first simplify the network (get rid of the 
multiple lines) using the Network>Create New Network>Transform>Remove> 
Multiple Lines>Single Line command. Pajek will ask if you want to create a new 
network; click “Yes,” and Pajek will generate a new network, probably called, 
“Simplification (Single Line) of N1 (67).” 
 

3. With this network appearing in the top network dropdown box, once again use the 
Network>Info>General command, accept Pajek’s defaults, and click “OK.” This 
will generate a new report that looks quite similar to the previous report, except 
that the density and average degree scores are exactly half of what they are in 
Figure 11. See Figure 12, next page. Typically, we use the density score 
calculated without loops (i.e., not including the diagonal). You’ll note that scores 
shown in Figure 12 are the same as those we found earlier (Figures 1 and 8). 

 
 
 
 
 

Network>Create New 
Network>Transform 

>Remove>Multiple Lines 
>Single Line  

 
 
 
 

Network>Info>General 
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Figure 12: Pajek Network General Info Report 

4. Let’s check to see if Pajek gives us the same scores in terms of network size, 
average distance, and diameter as UCNET. Make sure that the network appears in 
the first network drop-down box. The number in parentheses indicates the size of 
the network (67). To obtain a network’s average distance and diameter in Pajek, 
select the Network>Create New Vector>Distribution of Distances* command. 
This will generate a report (Figure 13) that indicates the number of unreachable 
pairs (i.e., pairs of actors that are neither directly nor indirectly tied to one 
another), the average distance between reachable pairs (3.35414), and the names 
of the actors most distant from one another along with the distance/diameter (9). 
Both of these agree with what we found earlier with UCINET. 
 

 
Figure 13: Pajek’s Distribution of Distances Report 

5. To calculate centralization, we use the same command for calculating degree 
centrality: Network>Create Vector>Centrality>Degree>All. However, we need 
do this with the network we created without multiple lines. Otherwise, Pajek will 
give an error, saying that it can’t compute centralization because it the network 
has multiple lines. The command generates a report that gives network 
centralization scores (Figure 14), which is the same as UCINET’s. If we want 
centralization based on closeness, betweenness, or eigenvector centrality we use 
the following commands: Network>Create Vector>Centrality>Closeness>All; 
Network>Create Vector>Centrality>Betweenness; and Network>Create 
Vector>Centrality>Hubs-Authorities. Note that for eigenvector centrality we use 
“Hubs-Authorities;” that is because with undirected networks, hubs and 

 
 
 
 

Network 
>Create Vector 

>Distribution of Distances* 

 
Network>Create Vector 

>Centrality>Degree>All 
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authorities are the same as eigenvector centrality. We’ll discuss this more in the 
lab that considers centrality measures. 
 

 
Figure 14: Pajek’s Degree Centralization Report 

6. Finally, to calculate the clustering coefficient, use Pajek’s Network>Create 
Vector>Clustering Coefficients>CC1 command. This creates one partition and 
two vectors as well as generates a report that indicates the Watts-Strogatz 
clustering coefficient score (Figure 15). 

 

 
Figure 15: Pajek’s Degree Clustering Coefficient Report 

7. In order to save all of your work, save it as a Pajek Project File: File>Pajek 
Project File>Save (or F2). As noted previously, project files are great for storing 
all of your work in a single file. 
 

 
Network>Create Vector 
>Clustering Coefficients 

>CC1 

File>Pajek Project File 
>Save 


