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In this lab, we will look at techniques for combining relational data with attribute data. Sometimes 
we’ll use the attribute data to highlight different aspects of the network. At other times, we’ll use 
it to simplify the networks. For this exercise, we’ll use the Anabaptist Leadership network and its 
related attribute data, both of which can be found in the zipped file: SNA Basics(Data).zip. 
The dataset includes 67 actors, 55 who were 16th century Anabaptist leaders and 12 who were 
prominent Protestant Reformation leaders (e.g., Martin Luther, John Calvin, Ulrich Zwingli, 
Martin Bucer, and Philip Melanchthon) who had contact with and influenced some of the 
Anabaptist leaders included here. Drawing on numerous sources (e.g., Bender, Friedmann and 
Klassen 1990; Clasen 1972; Klötzer 2007; Krahn, van der Zijpp and Stayer 1987; Stayer 1979; 
Williams 1975), McLaughlin (2015) expanded network data originally collected by Matthews et 
al. (2013) that included 49 actors but didn’t include relational data on some prominent Anabaptist 
leaders, such as Menno Simons, from whom contemporary Mennonites take their name. 
 

Part I – Simplifying (Collapsing) Networks in NetDraw 
 
1. Open NetDraw. In NetDraw open the “Anabaptist Leaders.##h” file using 

the File>Open> Ucinet dataset>Network command or by clicking on the open 
folder icon. The network should appear visually in the NetDraw screen. Next, 
open the related attribute file (“Anabaptist Attributes.##h”) using the 
File>Open>Ucinet dataset>Attribute data command or by clicking on the open 
folder icon with an “A” next to it. If you want to examine the attribute data, you 
can bring up NetDraw’s attribute editor with the Transform>Node attribute editor 
command. There you should see the node labels along with their attributes. 

 
2. NetDraw offers users several layout options that can be found under the Layout 

menu: Non-metric multidimensional scaling, Gower (metric scaling), 
Scaling/Ordination, Principal, Circle, and Random layouts. You may want to 
experiment with the various drawing algorithms to see which ones draw the 
network “best” (i.e., the drawing that you believe best illuminates the underlying 
structure, if there is one). 
 

3. There are various ways to include attribute data in our visualizations; here we will 
look at few. We can adjust the size, shape, and/or the color of the nodes to reflect 
different attributes, using the Properties>Nodes>Symbols set of commands. In 
the example below, node color indicates whether the actor was an Anabaptist or 
not (i.e., blue = Anabaptist; red = non-Anabaptist) and the shape indicates if they 
participated in the Münster Rebellion or not (circle in box = participated; square = 
did not participate). We didn’t vary the node size for any of the attributes because 
you typically only want to do that with continuous or ordered variables, and there 
aren’t any included with this particular dataset. “Age” at the time of the Münster 
Rebellion would be an example of an attribute with which we could vary the size 
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of the node if those data were included. In any event, depending on what layout 
options you finally chose, your drawing should look something like Figure 1. 
 

 
Figure 1: NetDraw Drawing of Noordin, Nodes Reflecting Various Attributes 

4. It is often hard to make sense of large networks, which is why shrinking 
(collapsing) or extracting a subset of a network can aid the analysis process. To 
shrink/collapse a network based on actors’ attributes (in this case, actors’ 
religious tradition), select NetDraw’s Transform>Collapse Nodes by attribute 
command, which brings up the dialog box (Figure 2). Use the pull-down menu to 
select the “Tradition” attribute, select NetDraw’s “Frequency” setting for 
calculating the value of ties, and click OK. This will yield a graph similar to 
Figure 3 (next page).  

 

 
Figure 2: NetDraw’s Collapse Nodes by Attribute Dialog Box 

5. You might be asking, “What just happened?” Good question. When we collapse 
or shrink a network based on a particular attribute (in this case, religious 
tradition), every actor who is coded as, say, a Melchiorite is now collapsed into a 
single “Melchiorite” node. Similarly, every actor who is coded as a Lutheran is 
now collapsed into a single “Lutheran” node. And the strength of the tie between 
the Melchiorite and Lutheran node is the count (i.e., frequency) of the ties 
between all Melchiorites and Lutherans in the network. If the ties between actors 
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were valued, then we might have wanted to choose “sum” instead of “frequency.” 
Since NetDraw doesn’t know what tradition each of the various #s refers to, it 
can’t assign meaningful labels to the collapsed nodes. Thus, it places the letter 
“G” in front of all of the types of roles along with the number corresponding to 
that particular tradition’s assigned number. 
 

 
Figure 3: Anabaptist Leader Network Collapsed by Attribute 

6. We can change the labels by using NetDraw’s Properties>Nodes>Labels>Text 
command. Scroll to the bottom of the dialog box (Figure 4, next page), and under 
the label column you will find the various labels assigned to the collapsed nodes 
by NetDraw. The tradition to which the various #s refer are as follows:  

 

1 = Melchiorite 
2 = Swiss Brethren 
3 = Denck 
4 = Hut 
5 = Hutterite 
6 = Other Anabaptist 
7 = Lutheran 
8 = Reformed 
9 = Other Protestant 

 

Enter the labels in the dialog box, click “Apply,” and close the box. Your network 
drawing should look similar to Figure 5 (next page). You’ll note that the layout 
differs slightly from Figure 4. In Figure 4, NetDraw drew node G-1.000 
(Melchiorites) directly on top of node G-7.000 (Lutherans). In Figure 5, I 
separated the two so that they can both be seen. 
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Figure 4: Relabeling Collapsed Network Nodes 

 

 
Figure 5: Anabaptist Leader Network Collapsed by Attribute (Relabeled) 

 
Part II – Simplifying (Extracting) Networks in UCINET 

 
1. In this section we will see how we can extract subsets of a network in UCINET. 

UCINET’s extraction capabilities aren’t as robust as Pajek’s, but they still offer 
analysts some useful tools. To extract subnetworks in UCINET, we use its Data> 
Subgraphs from partitions function, which will bring up a dialog box similar to 
the one displayed in Figure 6 (next page). Load the leadership network in the 
“Input network” box using the browse button to the right, and then load the 
attribute file in the “Input Partition” box using the browse button to its right. 
Next, click on the “L” speed button, which will call up a list of the various 
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attributes (not shown), select “Anabaptist,” and click okay. After doing all this, 
the dialog box should look quite similar to Figure 6. You can see that there are 
two “classes” in this attribute (0 = non-Anabaptist; 1 = Anabaptist), one which 
consists of 12 actors and one which consists of 55. Now, click OK, and this will 
create two new subnetworks of 12 and 55 actors respectively. 
 

 
Figure 6: Subgraph Extraction Dialog Box 

2. Open the larger network (probably has been assigned the name, “Anabaptist 
Leaders-1.##h”) in NetDraw, and it should look similar to Figure 7. What is 
notable is that the network is now split into two groups. Melchiorites make up a 
large portion of the group on the left. It suggests that at least among Anabaptist 
leaders, it was non-Anabaptists such as Martin Luther and Ulrich Zwingli, who 
tied to the two groups together. 

 

 
Figure 7: Anabaptist Leader Network 
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Part III – Simplifying Networks in Pajek1 
 
1. From the main screen open the Anabaptist Leader project file (rather than the 

network file), using the File>Pajek Project File>Read command. Pajek project 
files are a nice feature of Pajek because in them you can store more than just 
network data. In this case, the project file includes the leader network and all of 
the associated attribute data. 
 

2. Pajek handles attributes in two ways—as partitions and vectors. In Pajek a 
partition of a network is a classification or clustering of the actors (i.e., nodes, 
vertices) such that each actor is assigned to exactly one class or cluster. In other 
words, in Pajek partitions indicate nominal or discrete characteristics of actors. A 
property is nominal or discrete if it consists of a limited number of classes; for 
example, we may code the nationalities of actors such that class “1” includes 
leaders who operated primarily in Austria, class “2” indicates actors who operated 
primarily in Germany, “3” in Moravia, and so on. Partitions generally contain a 
limited number of classes, most of which contain several actors because they 
represent groups of actors rather than individual ones. Consequently, partitions 
can be quite useful for reducing a network’s size and complexity. In Pajek vectors 
are continuous attributes of actors, such as an actor’s education, age, their 
centrality scores, etc. Because continuous properties do not group actors into 
discrete classes, we do not use them to reduce a network. 
 

3. When Pajek reads a network, it displays its name in the network dropdown box, 
which lists all of the networks that have been read into Pajek. Pajek handles 
partitions and vectors the same way. Every partition and vector read into Pajek is 
displayed in the partition and vector dropdown boxes. The active network, 
partition, and vector are those that appear in the top dropdown network, partition, 
and vector boxes. 
 

4. We will begin by first visualizing the network, using religious tradition as an 
attribute to distinguish the actors from one another. Make sure that the network 
appears in the top dropdown network box (it should automatically since it is the 
only network included in the project file) and the “Tradition” appears in the top 
partition dropdown box (see Figure 8, next page). Next, draw the network and the 
partition simultaneously using the Draw> Network + First Partition command or 
by selecting the box to the right of the partition dropdown box and then clicking 

                                                
1 This portion of the lab is adapted from W. de Nooy, A. Mrvar, and V. Batagelj. 2011. Exploratory 
Social Network Analysis with Pajek. Cambridge, UK: Cambridge University Press (Chapter 2). 
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on the draw speed button to the right of the network dropdown box (circled in 
Figure 8). 
 

 
Figure 8: Pajek Main Screen 

5. Use the Pajek layout commands to “energize” the drawing. Remember that before 
“energizing” your drawing, you first need to indicate whether the connections 
between actors indicate similarities or dissimilarities in the Options>Value of 
Lines submenu of the Draw screen. When you choose Similarities, a higher line 
value between two actors causes them to be drawn closer together. Your drawing 
should look similar to Figure 9 but probably not identical. Note that all of the 
nodes to the left are colored yellow; those are the Melchiorites. They are clearly 
the largest group, and a portion of them played instrumental roles in leading the 
Munster Rebellion. Menno Simons was one that did not, however; he rejected the 
violence that some of his fellow Anabaptists perpetrated there, which is a large 
reason shy contemporary Anabaptists (Amish, Mennonites) also reject violence. 

 

 
Figure 9: Anabaptist Leadership Network; Color = Religious Tradition 

Layout>Energy 
>Kamada-Kawai, 

Fruchterman Reingold 
 

Options>Values of Lines 
>Similarities, 

Dissimilarities 



SNA Basics #3 
Simplifying Networks 

 

ã Sean F. Everton     
 

8 

6. You can change the background by choosing the Colors>Background option 
under the Options menu of the draw screen. You can also change partition colors 
by selecting the Colors>Partition Colors>for Vertices option under the Options 
menu. The gray-scale alternatives are attractive when you use partitions where the 
classes (or clusters) are ordered but not necessarily continuous (e.g., management 
level in an organization). They are also helpful when publishing in a journal or 
book where you cannot use color. 

 
7. Let’s shrink (i.e., collapse) the leadership network based on the actors’ religious 

tradition. Make sure that the network is showing in the top Network dropdown 
box and the tradition partition is showing in the top Partition dropdown box. 
Under the Operations menu, select the Network + Partition>Shrink Network 
option. A dialog box (not shown) will ask you for the minimum number of 
connections between clusters, which is the minimum number of lines that must 
exist between shrunk actors in order there to be a new line drawn between them. 
Generally, you will want to choose 1, which is the default. In the same dialog 
box, you may also choose a class of actors (i.e., cluster) not to shrink. Here, 
however, we want to shrink all of the classes, so type in any class number that is 
not in your partition (e.g., 99). Pajek shrinks all classes except the selected class 
and adds the shrunken network to the Network drop list (Figure 10). Note that the 
new network indicates that it is based on the first network (N1) and was shrunk 
according to the 15th partition (C15). It also indicates that it includes 9 actors. 
 

 
Figure 10: Pajek Main Screen Displaying New Shrunken Network 

8. Like NetDraw, Pajek does not know the meaning of these classes, so it cannot 
assign meaningful labels to the shrunken classes. It chooses the label of the first 
actor of a class that is shrunk and adds a “#” sign in front of the label. If there is 
only one actor in a particular class, it lists the actor’s name without a # sign. 
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Figure 11: Collapsed Anabaptist Leadership Network (Labels Unchanged) 

9. Pajek’s Shrink Network command also creates a new partition called ‘Shrinking’ 
– along with the new network identifying the classes in the partition that was used 
to shrink the original network. You can change the names by manually editing the 
shrunk partition using the File>Partition>View/ Edit command. The drawing in 
Figure 12 is of the collapsed network after the names of the shrunken classes have 
been changed to reflect the various religious traditions. The colors vary according 
to the new shrunken partition. 
 

 
Figure 12: Collapsed Anabaptist Leadership Network 

10. Now, let’s add two partitions together to create a new one (easy to do in Pajek). 
In particular, if we add the Anabaptist and Melchiorite partitions, the resulting 
partition will distinguish between those who are Melchiorites (= 2), non-
Melchiorites (= 1), and non-Anabaptists (= 0). To do this, first in the top partition 
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dropdown box select the Anabaptist partition and in the second partition 
dropdown box, select the Melchiorite partition (Figure 13). Next, select Pajek’s 
Partitions>Add (First + Second) command. This will create a new partition 
(probably called “Sum of C5 and C6”). 
 

 
Figure 13: Pajek Main Screen Displaying Two Partitions 

11. Let’s use this new partition to shrink the network. Following the same commands 
as before (except now we want the new partition in the top partition dropdown 
box), shrink the network (be sure to indicate that the class you don’t want shrunk 
= 99). This will produce a network with three actors (Melchiorite, non-
Melchiorite, and non-Anabaptist) that look should look similar to Figure 14 (after 
the labels have been entered). It isn’t too exciting, but it shows how non-
Anabaptist Protestants are what connect the Melchiorites with all other 
Anabaptists. 
 

 
Figure 14: Collapsed Anabaptist Leadership Network 
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12. Next, we’ll extract those actors within the network who operated primarily in 
Germany and Switzerland. To do this we will need to make sure that the original 
network (i.e., all 67 actors) is showing in the Network dropdown box and the 
primary country of operation partition is showing in the Partition dropdown menu 
(see Figure 15). 
 

 
Figure 15: Pajek Main Screen 

13. Under the Operations menu, select the Network + Partition>Extract> 
SubNetwork Induced by Union of Selected Clusters command. A dialogue box 
will appear that asks you which clusters (i.e., classes) to select. Choose clusters 
“2” (Germany) and “5” (Switzerland). See Figure 16. Combining clusters like this 
into a single network is something that Pajek can do, but UCINET cannot. 
 

 
Figure 16: Extract Subnetwork Dialog Box 

14. Pajek produces a new network that contains 37 actors. Visualize it using the 
Draw>Network command. You should end up with a network that looks similar 
to Figure 17 (next page) where the blue nodes indicate those individuals who 
operated primarily in Germany and red indicates those who operated primarily in 
Switzerland. 
 

15. It goes without saying that the original partitions don’t fit with the new network, 
since the former includes 67 actors and the latter only 37. However, with Pajek 
we can also extract subpartitions. To illustrate, make sure the original “tradition” 
partition is in the top partition dropdown box and the “primary country of 
operation” partition is in the second (not shown). Then use Pajek’s 
Partitions>Extract SubPartition (Second from First) command; in the dialog box 
(not shown) select 2 and 5. This will create a new “tradition” partition consisting 
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of 37 actors. If you visualize the subnetwork of 37 actors along with this new 
partition, you’ll get a network graph that looks similar to Figure 
 

 
Figure 17: Leadership Network Operating in Germany and Switzerland 
 
 

 
Figure 18: Network Operating in Germany and Switzerland by Tradition 
 

16. A nice feature of Pajek is that it lets you save all the files you have created into a 
single “project file.” To do this go to the main Pajek screen (not the Draw screen) 
and select the File>Pajek Project File>Save command or use the F2 function 
key. This will bring up a dialogue box that allows you to assign a name to the 
project file. 
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