
SNA Basics #4 
Multi-relational Network Data 

 

ã Sean F. Everton 
 

1 

Up to this point, we’ve focused on single types of relationship among actors: friendship, kinship, 
operations, etc. Most actors, however, are connected to others in various ways, and these ties can 
push and pull us in different (and sometimes contradictory) ways. For example, most individuals 
have friendship, kinship, and work ties; firms exchange personnel, money, information, and form 
alliances; and countries exchange culture, economic goods, and politics (e.g., ambassadors), as 
well as fight with and against one another. Thus, coding multi-relational data increase the 
probability that we’re mapping (coding) the network accurately. That is why this lab introduces 
some of the tools for combining, extracting, and analyzing multiple relations among actors. 
 
The data we will use in this exercise are the Sampson Monastery network data collected by 
Samuel Sampson. Sampson observed and recorded the social interactions among a group of 
novices (men who were preparing to join a monastic order). He recorded four types of “ties”: 
esteem (SAMPES) and disesteem (SAMPDES); liking (SAMPLK – three different time periods 
recorded) and disliking (SAMPDLK – one-time period recorded); positive influence (SAMPIN) 
and negative influence (SAMPNIN); praise (SAMPPR) and blame (SAMPNPR). Each novice 
only ranked his top three choices for each type of tie where a 3 indicates their first choice, a 2 
their second, and a 1 their third (some subjects offered tied ranks for their top four choices). 
During Sampson’s period of observation, a “crisis in the cloister” occurred in response to some of 
the changes proposed by the Second Vatican Council (Vatican II). This led to the expulsion of 
four novices and the voluntary departure of several others. Based on his observations, Sampson 
partitioned (i.e., sorted, divided) the novices into four groups: (1) the young turks, (2) the loyal 
opposition, (3) the outcasts, and (4) the neutrals. The young turks arrived later and questioned 
some of the monastery's practices, which the loyal opposition defended. The outcasts were 
novices that weren’t accepted by the larger group, and the neutrals were those who didn’t take 
sides in the debate. Most of the loyal opposition had attended a seminary, “Cloisterville,” prior to 
their arrival at the monastery. The data are in the zipped file, SNA Basics #4 (Data).zip. 

 
Part I – Multi-relational Data in UCINET and NetDraw 

 
1. One of the most common ways of storing multiplex data is to “stack” a set of 

actor-by-actor matrices, one for each relation. Figure 1 (next page) displays part 
of the output from a Data>Display command for the Sampson Monastery data set 
(SAMPSON.##h). Next, using UCINET’s spreadsheet (or Excel) function, open 
the file as a spreadsheet and note that each matrix is stored on a separate sheet. 
 

2. Before looking at the variety of tools included in UCINET for analyzing multi-
relational data, let’s visualize the Sampson data using NetDraw. NetDraw allows 
us to use multiple lines (with different colors or styles) and overlay one relation 
on top of another if the data are stacked as multiple matrices within the same file. 

 
[UCINET] 

Data>Display  
 

Data>Data editors 
>Matrix Editor, Excel 

Matrix Editor 
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Figure 1: UCINET Output log displaying Sampson’s Monastery Data 

3. Open the “SAMPSON.##h” dataset, using the File>Open>Ucinet dataset> 
Network command. This calls up a “Rels” (i.e., Relations) dialog box, which 
allows you to select which matrix to view; this is useful for switching back and 
forth between relations. To see how this works, click on the various relations 
boxes in the “Rels” dialog box (see Figure 2). You can either highlight one, two 
or all three relations at a time. You can also assign different colors to the various 
relations by using the dialog box (not shown) that is called up when you issue the 
Properties>Lines>Color>Relation command. 
 

 
Figure 2: NetDraw drawing of Sampson’s Monastery Data (drawn using MDS) 

[NetDraw] 
File>Open 

>Ucinet dataset 
>Network 

 
 
 
 
 

Properties>Lines 
>Color>Relation 
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4. Next, let’s look at how to unpack stacked network data in UCINET. To do this in 
UCINET, simply choose the Data>Unpack command. This brings up an 
“Unpack” dialog box (Figure 3) that asks for the input dataset and the relations to 
unpack. You can choose to unpack all of the relations or just some. UCINET’s 
default is “All” but if you wanted to only unpack some, you can select only those 
networks that you want. In this case, select all of the networks, click OK, and 
UCINET will generate ten separate matrices. 

 

 
Figure 3: UCINET Unpack dialog box 

5. It is easy in UCINET to combine separate matrices into a stacked dataset (i.e., just 
reverse what we did in step 4), using the Data>Join>Join Matrices command. 
This brings up a “Join” dialog box (Figure 4). Here, I’ve chosen to rejoin esteem 
(SAMPES), liking (SAMPLK3), positive influence (SAMPIN) and praise 
(SAMPPR) into a single file called “Sampson Positive Ties.” 
 

 
Figure 4: UCINET Join Dialog Box 

[UCINET] 
Data>Unpack 

 
Data>Join>Join Matrices 
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6. To create a single-valued matrix from a series of stacked matrices (like the 
Sampson data we just joined) we can use the Transform>Matrix Operations> 
Within dataset>Aggregations command, which brings up the following dialog 
box (Figure 5). After issuing this command, use the Data>Display command to 
see whether it worked as expected. 

 

 
Figure 5: UCINET Within Dataset Aggregations dialog box 

7. Assume that you haven’t combined various matrices into a single, stacked dataset, 
but you still want to combine (i.e., sum) two or more matrices into a single-valued 
matrix. UCINET allows you to do this as well (although it does not always work 
unfortunately) using the Transform>Matrix Operations>Between datasets> 
Statistical Summaries command, which brings up a dialog box (Figure 6). Click 
OK and UCINET combines the matrices into a single-matrix and displays a 
single-valued matrix in the output log. 
 

 
Figure 6: UCINET Between Dataset Statistical Summaries dialog box 

 
Transform 

>Matrix Operations 
>Within dataset 
>Aggregations 

 
Data>Display 

Transform 
>Matrix Operations 

>Between datasets 
>Statistical Summaries 
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8. Finally, you may be interested in determining how correlated networks are with 
each other. For example, if you are working with the Noordin data, you may 
hypothesize that ties formed through school affiliation form the basis of 
communication ties. Or with regards to the Sampson data you may hypothesize 
that high esteem (SAMPES) for someone will often translate into feelings of 
affection (SAMPLK3) for that person. To test such a hypothesis, we use 
UCINET’s Tools>Testing Hypotheses>Dyadic (QAP)>QAP Correlation 
function, which calls up the following dialog box (Figure 7). Using the Browse 
button, we identify the two (or more) networks that we are interested in 
calculating the correlation between and then click “OK.” This generates an output 
log (not shown) that indicates the correlation (Pearson) between the networks. Of 
course, you don’t have to be testing a hypothesis in order to use this function. 
You may be conducting exploratory data analysis and are simply interested in 
seeing which networks are highly correlated with one another and which ones are 
not. 
 

 
Figure 7: UCINET QAP Correlation Dialog Box 

Part II – Multi-relational Data in Pajek 
 

1. Pajek also has features for visualizing networks with multiple relations. Read in 
the “Sampson Positive Ties.net” network data, using the File>Network>Read 
command. Next, visualize the network using the Draw>Network command and 
once at the Draw screen, energize it using one of Pajek’s layout algorithms. Next 
(while still at Pajek’s Draw screen), tell Pajek that you want to vary the color of 
the relations by type of tie, by selecting the Options>Colors>Arcs>Relation 

 
 
 
 
 
 

Tools 
>Testing Hypotheses 

>Dyadic (QAP) 
>QAP Correlation 

[Pajek] 
File>Network>Read 

 
Draw>Network 

 
 

[Draw Screen] 
Options>Colors 

>Arcs>Relation Number 
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Number command.1 This should change the color of the arcs by tie. You may 
need to reenergize the drawing in order for the tie colors to change. 

 
2. If you want to assign different colors to the ties, select the Options>Colors> 

Relation Colors command and in the resulting dialog box select the colors of your 
choice by clicking on the various colors and assigning them to a tie (.i.e., cluster – 
note that you can also select three default screens at the bottom of the dialog box). 

 
3. Finally, if you only want to observe some of the ties, while still at the Draw 

screen select the Options>Lines>Draw Lines>Relation Ins command. This 
brings up the dialog box pictured below (Figure 8). Indicate which types of ties 
you want to view (I’ve selected 2 and 3) and click OK. The resulting network 
drawing (not shown) should only be of the selected relations. 

 

 
Figure 8: Pajek Relation Selection Dialog Box 

 
Part III – Positive and Negative Relations in UCINET and Pajek 

 
1. Now, we’ll try something a little more complex. The Sampson data contain both 

positive (e.g., like) and negative (dislike) ties. We’re going to multiply one of the 
negative networks (“dislike”) by “-1” in order to transform the values into 
“negative” values and then add this to one of the positive networks (“like” at time 
3) so that the combined network will contain both positive and negative ties. We 
will then export this network to Pajek and visualize it. 
 

2. Begin by confirming that the negative disliking relation (SAMPDLK) is coded 
with positive numbers by displaying this file in UCINET using the Data>Display 
command. Next, transform these positive values into negative ones using the 
Transform>Matrix Operations>Within dataset>Cellwise Transformations 
command. This brings up the following dialog box (Figure 9). Note as my input 
dataset I have selected SAMPDLK, as my output dataset I’ve chosen 
SAMPDLK2 as the name of the transformed dataset and checked the “Negative” 
box from among the “Transformation” options. Click “OK” and the output log 
should indicate that the values in the new matrix are negative. 

                                                
1 If the ties were edges (i.e., there is no directionality to the tie) instead of arcs (where there is), 
then we would select the Options>Colors>Edges>Relation Number command. 

 [Draw Screen] 
Options>Colors 

>Relation Colors 
 

[Draw Screen] 
Options>Lines 

>Draw Lines>Relation Ins 

 
[UCINET] 

Data>Display  
 

Transform 
>Matrix Operations 

>Within dataset 
>Cellwise Transformations 
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Figure 9: UCINET Within Dataset Cellwise Transformations Dialog Box 

3. The next step is to add this new matrix to the SAMPLK3 matrix, using the 
Transform>Matrix Operations>Between datasets>Statistical Summaries 
command (Figure 10). 
 

 
Figure 10: UCINET Between Dataset Statistical Summaries Dialog Box 

4. After UCINET finished processing the command, an output log will appear that 
should show an aggregated matrix containing both positive and negative numbers 
(see Figure 11). 
 

Transform 
>Matrix Operations 

>Between datasets 
>Statistical Summaries 
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Figure 11: UCINET Between Dataset Statistical Output Log 

5. Now use the Data>Export>DL command to export this aggregated matrix to 
Pajek. The reason we use this command to export the data rather than the 
Data>Export>Pajek>Network command is because (at least currently) when you 
use the latter command, UCINET exports the negative cell values as positives. 
Remember to change the extension of the exported file to .dat (see Figure 12).  
 

 
Figure 12: UCINET DL Export Dialog Box 
 

Data>Export>DL 
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6. Open Pajek and read in the network data you just exported from UCINET using 
the File>Network>Read command. Next, visualize the network using the Draw> 
Draw command and the energize it using one of Pajek’s mapping algorithms 
(either Kamada-Kawai or Fruchterman Reingold or both). Note that in Figure 13 
that there are both solid lines and negative lines between the nodes. In Pajek solid 
lines indicate positive connections while dotted lines indicate negative 
connections. If the nodes are hard to distinguish with all of the lines, you can 
increase their size using the Options>Size>of Vertices command in Pajek’s Draw 
screen. (Note: Sometimes when you first draw the network in Pajek, no lines 
appear. If this happens, close and reopen Pajek, and then try drawing the 
network again. This usually does the trick.) 
 

7. The drawing below (Figure 13) uses a vertex size of 10.  Generally, however, it is 
wise to use the default setting (“0”), which lets Pajek automatically set the size of 
the vertices.  This is an especially useful option when node size reflects an 
attribute that varies considerably (e.g., age, centrality, etc.). 
 

 
Figure 13: Pajek Drawing of Sampson Monastery Liking and Disliking Data 

[Pajek] 
File>Network>Read 

 
Draw>Network 

 
Layout>Energy 

>Kamada-Kawai>Free 
 
 
 

Options>Size>of Vertices 


