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Social scientists generally assume that “social interaction is the basis for solidarity, shared norms, 
identity, and collective behavior, so people who interact intensively are likely to consider 
themselves a social group.”1 Thus, a major focus of social network analysis is to identify dense 
clusters of actors “among whom there are relatively strong, direct, intense, and/or positive ties.”2 
These are typically referred to as “cohesive subgroups,” “subnetworks,” or “sub-clusters.” One 
way to cluster actors is based on shared attributes (e.g., race, gender, etc.). Another is to use the 
pattern of ties among actors. That is the focus of this Lab. In an ideal world, there would be a 
single algorithm for identifying cohesive subgroups, but this is not an ideal world, so social 
network analysts have developed a variety of algorithms for identifying subnetworks. We won’t 
consider all of them; there are simply too many. Instead, we will focus on just a few. 
 
For this exercise, we’ll use a portion of the Chimeric Religious Terrorist Network (CRTN) that 
appears in described in Chapter 3 of the book. Data were collected from 1989 to 2004 on a 
religiously inspired terrorist group, but the researchers who originally gathered the data later 
determined that the data were a poor reflection of reality, which is why we refer to it here (and in 
the book) as the CRTN. It consists of 366 actors, who had preexisting ties before joining the 
group, formed ties after joining the group, or participated in the same operations. Here we focus 
on those who participated in the same operation. 
 

Part I – Identifying Subgroups in UCINET and NetDraw 
 
1. Open NetDraw and read the “CRTN-Shared Operations” into NetDraw. Since 

there are a lot of actors, you’ll probably want to turn off the labels with the L 

speed button or with the Properties>Nodes>Labels>Visible command. Both 
bring up a dialog box (not shown) where you can the appropriate boxes and hide 
the labels. It will also be helpful to hide the isolates with the isolate speed button 
(Iso). 
 

2. We will begin by looking at components, which are subgroups that are connected 
within but disconnected between subgroups. In directed networks, you can 
identify two types of components: strong and weak. Strong components take into 
account the direction of the ties, whereas weak components do not. With 
undirected networks, you can only identify weak components, which means that 
if you ask UCINET or Pajek to identify strong components in an undirected 
network, you’ll get the same result that you would get if you asked them to 
identify weak components. To identify components in NetDraw, use the 
Analysis>Components command. NetDraw includes the helpful option of having 

                                                
1 Wouter de Nooy, Andrej Mrvar, and Vladimir Batagelj. 2005. Exploratory Social Network 
Analysis with Pajek. Cambridge, UK: Cambridge University Press: 61. 
2 Stanley Wasserman and Katherine Faust. 1994. Social Network Analysis: Methods and 
Applications. Cambridge, UK: Cambridge University Press: 249. 
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it identify components by color or shape. Choose one or the other. You should get 
a network map that looks similar to Figure 1 where each color indicates a 
different component. In many ways, the figure is not terribly illuminating. 
However, you’ll note that there is one very large component (colored red in the 
figure below); this is known as the largest or “main” component, and it can 
sometimes be useful to extract the main component prior to conducting some 
form of analysis. We cannot extract the largest component in NetDraw, but we 
can in UCINET and Pajek. 
 

 
Figure 1: Component Analysis of the CRTN Shared Operations Network 

3. Clique analysis is not always that useful because requiring everyone to have a tie 
to everyone else in order for it to be considered a group is a very restrictive 
definition of a group. Still, there are some useful aspects of clique analysis, which 
we will touch on when we get to UCINET (NetDraw doesn’t have a clique 
analysis function). 
 

4. The k in k-core indicates the minimum number of ties of each actor within the 
core, for instance, a 2-core includes all actors that have two or more connections 
to other actors within the core, and a 3-core includes all actors that have three or 
more ties to other actors within a core. It is important to note that a network’s 
highest k-core does not necessarily correspond to the highest degree centrality 
score obtained by an actor in the network. Rather, it is the subgroup in which 
every actor shares the largest number of ties. This is perhaps illustrated easier 
than explained. Imagine a network in which one actor has six ties but no one else 
has more than four. The highest k-core would not be a 6-core because everyone 
else in the subgroup would also need to have six ties. Most likely, it would a 4-
core. We can detect k-cores in NetDraw with its Analysis>K-Cores command, 
which automatically colors the nodes by the different k-cores to which each node 
belongs (see Figure 2). As you can see, it identifies more groups that the 

 
 
 
 
 
 
 
 
 
 
 
 

Analysis>K-Cores  



SNA Basics #6 
Identifying Subgroups 

 

ã Sean F. Everton  3 
 

components command did. If you want to see what k-core each actor belongs to, 
select the Transform>Node attribute editor command. If you scroll through, 
you’ll discover that the highest k-core is a 32-core. 
  

 
Figure 2: K-Core Analysis of the CRTN Shared Operations Network 

5. Now let’s consider another method for identifying subgroups: Girvan-Newman,3 
which a “community detection” algorithm, which you can access with the 
Analysis>Subgroups>Girvan-Newman command. This brings up a dialog box 
asking you for the minimum and maximum number of subgroups you want 
NetDraw to identify. Change NetDraw’s defaults so that the maximum number of 
groups is 50 and click “Run.” This should produce a report that provides a series 
of modularity scores (Q) associated with different levels of clustering where 
higher score indicates a better fit. In this case, a partition of 18 or 19 subgroups 
provides the best measure of fit (Q = .792). 
 

6. There is an upper limit to modularity scores, which is a function of the number of 
partitions (subgroups) the algorithm identifies – the fewer the number of 
partitions, the lower the maximum modularity score. Specifically, modularity has 
a maximum value of 1 − #

$
 where m equals the number of subgroups. An easy 

way to calculate this is to multiply the modularity score by $
$%#

:   

 
(0.792 ∗ #,

#-
= 0.839) vs. (0.792 ∗ #1

#,
= 0.836) 

 

                                                
3 Mark Newman has developed several community-detection algorithms. ORA implements 
both the Girvan-Newman and an additional Newman group algorithm. UCINET has recently 
added a few new community detection algorithms, one developed by Newman, but some 
developed by others. 
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Thus, if you have the same score for two different partitions, the partition with 
fewer subgroups will actually be a better fit than the partition with more 
subgroups. This means that the partition containing 18 subgroups represents a 
better fit than the partition that identifies 19. To visualize the 18-subgroup 
partition, select the Properties>Nodes>Symbols> Color>Attribute-based 
command, and then using the drop-down menu in the resulting dialog box (not 
shown), select the appropriate partition (it should say something similar to this: 
*ngPart_18 (Q=0.792). This should produce a network map similar to Figure 3. 
 

 
Figure 3: Girvan-Newman Analysis of the CRTN Shared Operations Network 

 

 
Figure 4: Collapsed CRTN Network by Girvan-Newman Subgroup 

7. Next, let’s shrink (collapse) the network like we did in the second lab, except this 
time we’ll use the Girvan-Newman partition as the attribute. Recall that attributes 
are non-relational aspects of networks. They can be either pre-given (e.g., role, 
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gender, nationality), or they can be generated by our analysis of a network. 
Clustering algorithms, such as k-cores and community detection algorithms, sort 
(i.e., partition) actors to various subgroups, and the subgroup “membership” 
partition becomes an actor attribute. 
 

8. To collapse the network based on the Girvan-Newman analysis, issue the 
Transform>Collapse Nodes by attribute command, which will bring up a dialog 
box. For an attribute select the partition that sorts the actors into 18 subgroups 
(*ngPart_18 (Q=0.792), and then click OK. This should collapse the network into 
18 groups (Figure 4, previous page). As you can see the subgroup of actors 
labeled the G-1 group appears to be quite central to the CRTN network. 
 

9. Let’s move to UCINET. We’ll begin with components. The relevant command is 
Network>Regions>Components>Binary (since our network consists of 0s and 
1s). At the dialog box (not shown), select the “CRTN-Shared Operations” 
network and click OK. This will generate two new files. One is a partition that 
indicates to which component each actor belongs; the other is a “two-mode” 
network where the rows are the actors and the columns are the components with 
which they are affiliated. It also produces an output that should look similar to 
Figure 5. As you can see, it indicates that the largest component contains 200 
actors, while the next largest component only contains 31. If you scroll down, 
you’ll notice there are a number of components of size 1 (i.e., isolates). Extracting 
the main component is straightforward with the Data>Filter/Extract>Main 
component command. The extracted network can be analyzed and visualized (in 
NetDraw) as a separate network. 
 

 
Figure 5: Component Analysis Output 
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10. We can detect k-cores in UCINET with the Network>Regions>K-Core command. 
At the dialog box, select the “CRTN-Shared Operations” network and click 
OK. This produces an output, some of which is reproduced in Figure 6 (you need 
to scroll down in order to see everything). However, not too far down, under the 
label “Degree,” UCINET tells us that the largest k-core is a 32-core, which is the 
same result we got in NetDraw. 
 

 
 Figure 6: K-Core Analysis Output 

11. UCINET implements Girvan-Newman with the Network>Subgroups>Girvan-
Newman command. Let’s use the main component that we extracted in step 9 
above (“CRTN-Shared Operations-main”). The default for the maximum 
number of partitions to 10, so in the dialog box (not shown) change this to 50 (we 
already know that it’s larger than 10), click OK, and UCINET generates an 
attribute file that contains a number of partitions. Unfortunately, it does not 
calculate modularity. For this, we need the Tools>Cluster Analysis>Cluster 
Adequacy function, which generates a dialog box similar to Figure 7. Note that in 
this case the “Input proximity matrix” is the CRTN-Shared Operations-main 
file and the “Input Partition” is the partition generated by the Girvan-Newman 
function (CRTN-Shared Operations-main-gn). 
 

 
Figure 7: UCINET Cluster Adequacy Dialog Box 
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12. When you click OK, UCINET should generate a log file that includes a lot of 
information. If you scroll to the bottom of the file, you will see a series of 
measures of fit. The second line (Q) is the modularity score, and if you compare it 
to what you got using NetDraw, they should agree. Note also that the output 
includes a Q-prime measure. In recent versions of UCINET, the cluster adequacy 
function hasn’t always worked (it produces an error message). If this happens, 
move on to the next step. 
 

13. UCINET now includes two new community detection algorithms that DO 
calculate modularity for you: Louvain method and Newman Community 
Detection, which you can access with the following commands: Network> 
Subgroups>Louvain method and Network> Subgroups>Newman Community 
Detection (NCD). The Louvain algorithm identifies two partitions, one with 13 
subgroups and one with 10 groups; the former has a modularity score of 0.700 
while the latter has a modularity score of 0.705 (the scores can be a little hard to 
pick out, but at least UCINET calculates it for us). The NCD algorithm generates 
several different partitions (145 when I tried it), each with a calculated modularity 
score. You have to scroll through to find the largest modularity score, which with 
large networks can be daunting. Nevertheless, at least you don’t have to use the 
cluster adequacy function. 
 

14. Finally, Clique analysis is accomplished in UCINET with the Network> 
Subgroups>Cliques command, which calls up a dialog box (not shown), which 
asks you to select the network you are analyzing. Let’s stick with the main 
component. Note also that the default is that it only looks for cliques of size 3 or 
greater. Keep this default. When you click OK, UCINET will generate a log file 
that looks similar to Figure 8, which tells you that it found 28 cliques. 
 

 
Figure 8: Clique Analysis Output 
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15. UCINET’s clique analysis generates a number of files, two of which we’ll 
consider here. One is a “two-mode” network where the rows are actors and the 
columns are cliques (cliques are somewhat unique in that an actor can belong to 
more than one clique). To do this, return to NetDraw and open the “Clique 
Sets” file. You should get a network map that looks similar to Figure 9 where 
you can clearly see that some individuals are involved in far more cliques than are 
others; similarly, some cliques are more central to the network. 
 

 
Figure 9: Clique Sets Network 

16. The other data file we will consider here is the “CliqueOverlap” file, where 
actors who share an affiliation with one or more cliques are tied with one another. 
It (Figure 10) is essentially the one-mode version of the clique sets network 
displayed in Figure 9. 
 

 
Figure 10: Clique Overlap Network 
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Part II – Identifying Subgroups in Pajek4 
 

1. Open the “CRTN-Shared Operations.net” network file using the File> 
Network>Read command. We will begin by looking at components using the 
Network>Create Partition>Components command, which allows us to identify 
three types of components: strong, strong-periodic (for time networks), and weak.  
When you execute the Strong or Weak command, a dialog box appears that asks 
for the minimum size of components. Accept Pajek’s default (“1”) and click OK.  
This generates a report (not shown) that tells you the size of the largest 
component (200) and how many components there are (81). It also creates a 
partition in which each class represents a component. Using the “Edit Partition” 
button (located just to the left of the partition drop box) or the File>Partition> 
Edit command, examine the new partition. Also inspect it using the Partition> 
Info command. Visualize the network and new partition using the Draw>Network 
+ First Partition command (make sure the new partition is highlighted in the 
partition drop-down box). Be sure to energize it with one of the available network 
drawing algorithms. 
 

2. We can extract the main component just like we did in the third lab with the 
Operations>Network + Partition>Extract>SubNetwork Induced by Union of 
Selected Clusters command. Be sure the component partition is in highlighted in 
the top drop-down partition box, issue the command, and at the dialog box, select 
cluster 1 (not 1-*). Click OK, and Pajek should generate a new network 
containing 200 actors. Draw the network and compare to your drawing of the 
main component in NetDraw. It should look similar to Figure 11. 
 

 
Figure 11: Pajek Drawing of Main Component 

                                                
4 This section is loosely based on de Nooy et al., Chapter 4. 

File>Network>Read  
 

Network>Create Partition 
>Components>Strong, 
Strong-Periodic, Weak 

 
 
 
 
 
 
 
 
 

File>Partition>View/Edit 
 

Partition>Info 
 

Draw>Network + First 
Partition 

Operations 
>Network + Partition 

>Extract>SubNetwork 
Induced by Union of 

Selected Clusters  
 

Draw>Network 



SNA Basics #6 
Identifying Subgroups 

 

ã Sean F. Everton  10 
 

3. Let’s stick with the main component. Before you identify k-cores using Pajek, 
you will first want to dichotomize and symmetrize the network so that Pajek only 
counts the number of each actor’s neighbors (rather than taking into account the 
value of those ties) and treats the ties as edges (rather than as arcs). I’ve already 
done this for you here, but if you have to do this, use Pajek’s Net> Transform> 
ArcsàEdges>All command. Let Pajek create a new network, using the 5 (Single) 
option. 
 

4. In Pajek, k-cores are detected with the k-Core command in the Network>Create 
Partition submenu. The Input, Output, and All commands distinguish between 
input cores (based on the number of ties pointing to an actor), output cores (based 
on the number of ties pointing away from an actor) and cores that ignore the 
direction of ties.  Most of the time you will want to use the All command and only 
apply it to simple undirected networks. The command yields a partition that 
assigns each actor to the highest k-core to which it belongs. What is the highest 
k-core? (Hint: look at the name of the new partition.) Draw the network with the 
k-core partition using the Draw>Network + First Partition command. It should 
look similar to Figure 12. 
 

 
Figure 12: Main Component K-Cores 

5. Pajek recently added the Louvain community detection algorithm. It is accessed 
with Pajek’s Network>Create Partition>Communities>Louvain Method 
command. Choose one of the two options, and then visualize the network with the 
newly generated partition Draw using the Draw>Network + First Partition 
command. Note that the partition indicates the level of modularity (Q) as well as 
the number of clusters (NC). You will generate a network map similar to Figure 
12 (next page). 
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Figure 12: Louvain Community Detection 

6. Pajek has implemented another community detection algorithm now available in 
Pajek is VOS (Visualization of Similarities) mapping that some believe does a 
better job than the Louvain method but is not as efficient with larger networks. It 
is implemented with the Network>Create Partition>Communities>VOS 
Clustering command (again, choose one of the two options). Visualize the 
resulting network and partition. How does this clustering compare to the 
Louvain Method? 
 

 
Figure 13: VOS Mapping Community Detection 

7. Finally, let’s shrink the network based on this last community detection 
algorithm. Under the Operations menu, select the Network + Partition>Shrink 
Network option. A dialog box (not shown) will ask you for the minimum number 
of connections between clusters, which is the minimum number of lines that must 
exist between shrunk actors in order there to be a new line drawn between them. 
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Generally, you will want to choose 1, which is the default. In the same dialog 
box, you may also choose a class of actors (i.e., cluster) not to shrink. As before, 
we want to shrink all of the classes, so type in any class number that is not in your 
partition. In this case, we can use the default (“0”) because there is no community 
assigned a value of 0. 
 

8. With the shrunken network highlighted in the top network drop-down box and the 
new partition in the top partition drop-down box, visualize the network, and you 
should get a network map that looks similar (but not necessarily identical) to 
Figure 14. Again, we see that certain subgroups appear to be more central to this 
network than are others. 
 

 
Figure 14: Shrunken Network Based on VOS Mapping Community Detection 

9. Pajek doesn’t really offer a clique analysis option (there is a workaround, but it 
isn’t worth exploring here), so that is all for now. 
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